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UNIT-2: Formulas, Chart and Data 

2.1 Charts :  

 2.1.1 Creating 2D and 3D charts ( Columns, Line, Pie, Bar, Scatter)  

 2.1.2 Difference among columns, Line and bar charts.  

2.2 Formulas:  

 2.2.1 sum, average, count, max, min, sumif, pmt, stddev  

 2.2.2 Logical ( if, AND, OR, NOT, TRUE, FALSE )  

 2.2.3 Date and Day function : Date, day, time, now, Hour, Minute, Second, Month, Days360, 

 weekday  

2.3 Data :  

 2.3.1 Sort Data, Filter Data  

 2.3.2 Text to columns, Remove Duplication  

 2.3.3 Consolidated Data ( sum, count, max, min, average) 

 

2.1 Charts  

• Charts are used to display series of numeric data in a graphical format. 

• It is used to make it easier to understand large quantities of data and the relationship between 

different series of data. 

 

2.1.1 How to create a chart?  

• Select Insert > Chart from the menu bar. OR click the Chart icon on the main toolbar. 

  
OR 

 

  
 



• To create a chart, first highlight (select) the data to be included in the chart.  

• The selection does not need to be in a single block, as shown below; you can also choose individual 

cells or groups of cells (columns or rows).  

 

 
 

• Step-1:  

Open office spread sheet different types of charts are available like Area, Bubble, Column and bar; 

Column and line,   Line, Net, Pie/donut, Stock, XY (scatter).  

Then Press Next button  as  shown in figure. 

You can select 3D look option to prepare 3D chart.  

 

 
 

• Step-2: 

Then it will ask you for select data range.  

Here select the data which we want to use in chart. 

And then press Next button. 



 
 

• Step-3:  

selecting data series.  

Here you can add the data that you want to include in the chart.  

Each named data series has its ranges and its individual Y-values listed.       

 
 

• Step-4:  

Chart Element.  

On this page, you can give your chart a title and, if desired, a subtitle.  

You can also give names to x axis and y axis.  

You can leave out the legend or include it and place it to the left, right, top or bottom.  

To finish the chart, click Finish. 

 



 
 

And it displays a chart as below. This chart is known as column chart. 

 
 

• Same way we can create Line chart, pi chart, Bar chart and scatter chart. As describe below. 

2.2 Formulas:  

2.2.1 sum, average, count, max, min, sumif, pmt, stddev  

• SUM : Adds all the numbers in a range of cells. 

Syntax : SUM(Number1; Number2; ...; Number30) 

here, Number 1 to Number 30 are up to 30 arguments whose sum is to be calculated. 

Example : 



   

• Average : Returns the average of the arguments. 

Syntax :AVERAGE(Number1; Number2; ...Number30) 

Number1; Number2;...Number 0 are numerical values or ranges. 

Example : =AVERAGE(F6:F15)  

 
 

• count: Counts how many numbers are in the list of arguments. Text entries are 

ignored. 
Syntax : =COUNT(Value1; Value2; ... Value30) 

Value1; Value2, ... are 1 to 30 values or ranges representing the values to be counted. 

Example : The entries 2, 4, 6 and eight in the Value 1-4 fields are to be counted. 

=COUNT(2;4;6;"eight") = 3.  The count of numbers is therefore 3. 
 

• max: Returns the maximum value in a list of arguments. 

 

Syntax : MAX(Number1; Number2; ...Number30) 

 Number1; Number2;...Number30 are numerical values or ranges.  

Example : =MAX(A1;A2;A3;50;100;200) returns the largest value from the list is  

            200. 



  =MAX(A1:B100) returns the largest value from the list. 

 

[Note****Returns 0 if no numeric value and no error was encountered in the cell range(s) 

passed as  cell reference(s).  

 Text cells are ignored by MIN() and MAX().  

 The functions MINA() and MAXA() return 0 if no value (numeric or text) and no error 

 was encountered.  

 Passing a literal string argument to MIN() or MAX(), e.g. MIN("string"), still results in an 

 error.] 

• min: Returns the minimum value in a list of arguments. 
 

Syntax : MIN(Number1; Number2; ...Number30) 

 Number1; Number2;...Number30 are numerical values or ranges.  

 

Example : =MIN(A1;A2;A3;50;100;200) returns the largest value from the list is  
            50. 
  =MIN(A1:B100) returns the largest value from the list. 
See figure of MAX function. 
 

• sumif: Adds the cells specified by a given criteria. This function is used to browse a  

  range when you search for a certain value. 
 

Syntax :SUMIF(Range; Criteria; SumRange) 

 

Range is the range to which the criteria are to be applied. 

Criteria is the cell in which the search criterion is shown, or the search criterion itself. If the 

criteria is written into the formula, it has to be surrounded by double quotes. 

SumRange is the range from which values are summed. If this parameter has not been 

indicated, the values found in the Range are summed. 

Example :To sum up only negative numbers: =SUMIF(A1:A10;"<0")  

=SUMIF(A1:A10;">0";B1:10) - > sums values from the range B1:B10 only if the  
     corresponding values in the range A1:A10 are >0. 

 

• pmt: Returns the periodic payment for an annuity with constant interest rates. 

 



 Syntax :PMT(Rate; NPer; PV; FV; Type) 

 

Rate is the periodic interest rate. 

NPer is the number of periods in which annuity is paid. 

PV is the present value (cash value) in a sequence of payments. 

FV (optional) is the desired value (future value) to be reached at the end of the periodic 

payments. 

Type (optional) is the due date for the periodic payments.  

 Type=1 is payment at the beginning and Type=0 is payment at the end of each period. 

 In the OpenOffice Calc functions, parameters marked as "optional" can be left out only 

 when no parameter follows.  

 For example, in a function with four parameters, where the last two parameters are 

 marked as "optional", you can leave out parameter 4 or parameters 3 and 4, but you 

 cannot leave out parameter 3 alone.  

Example : 

What are the periodic payments at a yearly interest rate of 1.99% if the payment time is 3 years 

and the cash value is 25,000 currency units. There are 36 months as 36 payment periods, and 

the interest rate per payment period is 1.99%/12. 

 

=PMT(1.99%/12;36;25000) = -715.96 currency units.  

The periodic monthly payment is therefore 715.96 currency units. 

 

• stddev: Estimates the standard deviation based on a sample. 
Syntax :STDEV(Number1; Number2; ...Number30) 

Number1, Number2, ... Number30 are numerical values or ranges representing a sample 

based on an entire population. 

Example: =STDEV(A1:A50)  

returns the estimated standard deviation based on the data referenced. 

 

2.2.2 Logical ( if, AND, OR, NOT, TRUE, FALSE )  

• if: Specifies a logical test to be performed. 

 

Syntax :IF(Test; ThenValue; OtherwiseValue) 

 

Test is any value or expression that can be TRUE or FALSE. 

ThenValue (optional) is the value that is returned if the logical test is TRUE. 

OtherwiseValue (optional) is the value that is returned if the logical test is FALSE. 

Examples:  =IF(A1>5;100;"too small")  

If the value in A1 is higher than 5, the value 100 is entered in the current cell; 
otherwise, the text “too small” (without quotes) is entered. 

 

[In the OpenOffice Calc functions, parameters marked as "optional" can be left out only when 

no parameter follows. For example, in a function with four parameters, where the last two 



parameters are marked as "optional", you can leave out parameter 4 or parameters 3 and 4, 

but you cannot leave out parameter 3 alone. ] 

  

For example If you want to calculate grade of student according to percentage then 

if condition is as below: 

 

=IF(H4>=70;"Distinction";IF(H4>=60;"First";IF(H4>=50;"Second";IF(H4>=40;"Pass";IF(
H4<40;"Fail"))))) 

 

 
 

• AND: Returns TRUE if all arguments are TRUE. If one of the elements is FALSE, this 

function returns the FALSE value. 

The arguments are either logical expressions themselves (TRUE, 1<5, 2+3=7, B8<10) that return 

logical values, or arrays (A1:C3) containing logical values. 

 

When a function expects a single value, but you entered a cell range, then the value from the cell 

range is taken that is in the same column or row as the formula. 

 

If the entered range is outside of the current column or row of the formula, the function returns the 

error value #VALUE! 

 

Syntax : AND(LogicalValue1; LogicalValue2 ...LogicalValue30) 

 

• LogicalValue1; LogicalValue2 ...LogicalValue30 are conditions to be checked.  

• All conditions can be either TRUE or FALSE.  

• If a range is entered as a parameter, the function uses the value from the range that is in 

the current column or row.  

• The result is TRUE if the logical value in all cells within the cell range is TRUE. 

 
Example :The logical values of entries 12<13; 14>12, and 7<6 are to be 
checked: 
 
=AND(12<13;14>12;7<6) returns FALSE. 



=AND (FALSE;TRUE) returns FALSE. 

 

• OR: Returns TRUE if at least one argument is TRUE. This function returns the value 

FALSE, if all the arguments have the logical value FALSE. 

 

The arguments are either logical expressions themselves (TRUE, 1<5, 2+3=7, B8<10) that return 

logical values, or arrays (A1:C3) containing logical values. 

 

When a function expects a single value, but you entered a cell range, then the value from the cell 

range is taken that is in the same column or row as the formula. 

 

If the entered range is outside of the current column or row of the formula, the function returns the 

error value #VALUE! 

 

Syntax : OR(LogicalValue1; LogicalValue2 ...LogicalValue30) 

• LogicalValue1; LogicalValue2 ...LogicalValue30 are conditions to be checked.  

• All conditions can be either TRUE or FALSE. 

•  If a range is entered as a parameter, the function uses the value from the range that is 

in the current column or row. 

 

• Example : The logical values of entries 12<11; 13>22, and 45=45 are to be 
checked. 
=OR(12<11;13>22;45=45) returns TRUE. 
=OR(FALSE;TRUE) returns TRUE. 

 

• NOT: Complements (inverts) a logical value. 

 

Syntax :NOT(LogicalValue) 

LogicalValue is any value to be complemented. 

Example: =NOT(A).  

If A=TRUE then NOT(A) will evaluate FALSE. 

 

• TRUE: The logical value is set to TRUE. The TRUE() function does not require any 

arguments, and always returns the logical value TRUE. 

 

Syntax : TRUE() 

Example 

If A=TRUE and B=FALSE the following examples appear: 

 

=AND(A;B) returns FALSE 

=OR(A;B) returns TRUE 

=NOT(AND(A;B)) returns TRUE 

 

• FALSE :Returns the logical value FALSE. The FALSE() function does not require any 

arguments, and always returns the logical value FALSE. 



Syntax: FALSE() 

Example 

=FALSE() returns FALSE 
=NOT(FALSE()) returns TRUE 

 

2.2.3 Date and Day function : Date, day, time, now, Hour, Minute, Second, Month, 

Days360,  weekday  

 

• Day : Returns the day of given date value.  

 
The day is returned as an integer between 1 and 31. You can also enter a negative date/time value. 

Syntax :DAY(Number) 

 

Number, as a time value, is a decimal, for which the day is to be returned. 

 

Examples  

=DAY(1) returns 31 (since OpenOffice starts counting at zero from   
    December 30, 1899) 
=DAY(NOW()) returns the current day. 
=DAY(C4) returns 5 if you enter 1901-08-05 in cell C4 (the date value might 
get formatted differently after you press Enter). 

 

• Date: This function calculates a date specified by year, month, day and displays it in  

  the cell's formatting.  
The default format of a cell containing the DATE function is the date format, but you can 

format the cells with any other number format. 

 

Syntax: DATE(Year; Month; Day) 

 

• Year is an integer between 1583 and 9957 or between 0 and 99. 

• Month is an integer indicating the month. 

• Day is an integer indicating the day of the month. 

• If the values for month and day are out of bounds, they are carried over to the next 

digit. If you enter =DATE(00;12;31) the result will be 12/31/00. If, on the other hand, you 

enter =DATE(00;13;31) the result will be 1/31/01. 

 

Example 
=DATE(00;1;31)  
display 1/31/00 if the cell format setting is MM/DD/YY. 

 

• Time : TIME returns the current time value from values for hours, minutes and  

  seconds.  
This function can be used to convert a time based on these three elements to a decimal 

time value. 

 

Syntax : TIME(Hour; Minute; Second) 

• Use an integer to set the Hour. 

• Use an integer to set the Minute. 

• Use an integer to set the Second. 



• Examples 

=TIME(0;0;0) returns 00:00:00 
=TIME(4;20;4) returns 04:20:04 

 

• Now : Returns the computer system date and time.  
   

  The value is updated when you recalculate the document or each time a cell value is  

  modified. 

 

Syntax : NOW() 

• NOW is a function without arguments. 

 

Example 

=NOW()  
returns the current time and date. 

 

• Hour : Returns the hour for a given time value.  
       The hour is returned as an integer between 0 and 23. 

 

Syntax : HOUR(Number) 

• Number, as a time value, is a decimal, for which the hour is to be returned. 

 
Examples 

=HOUR(NOW())  returns the current hour 
=HOUR(C4)  returns 17 if the contents of C4 = 17:20:00. 

 

• Minute : Same as Hour, it returns minutes for a given time. 

Calculates the minute for an internal time value. The minute is returned as a number 

between 0 and 59. 

Syntax : MINUTE(Number) 

Number, as a time value, is a decimal number where the number of the minute is to be 

returned. 

Examples 

 
 

• Second :  Returns the second for the given time value. The second is given as an  

  integer between 0 and 59. 
 
Syntax : SECOND(Number) 

• Number, as a time value, is a decimal, for which the second is to be returned. 

 
Examples 



=SECOND(NOW()) returns the current second 
=SECOND(C4) returns 17 if contents of C4 = 12:20:17. 
 

• Month :  Returns the month for the given date value. The month is returned as an       

  integer between 1 and 12. 
 

Syntax : MONTH(Number) 

Number, as a time value, is a decimal for which the month is to be returned. 

Examples 

=MONTH(NOW())  returns the current month. 
=MONTH(C4)  returns 7 if you enter 2000-07-07 to cell C4 (that date  
   value might get formatted differently after you press  
   Enter). 

 

• Days360:Returns the difference between two dates based on the 360 day year used  

  in interest calculations. 
 
Syntax: DAYS360("Date1"; "Date2"; Type) 

• If Date2 is earlier than Date1, the function will return a negative number. 

• The optional argument Type determines the type of difference calculation.  

• If Type = 0 or if the argument is missing, the US method (NASD, National Association of 

Securities Dealers) is used.  

• If Type <> 0, the European method is used. 

 
Examples 

=DAYS360("2000-01-01";NOW())  
returns the number of interest days from January 1, 2000 until today. 

 

• Weekday : Returns the day of the week for the given date value.  

 The day is returned as an integer between 1 (Sunday) and 7 (Saturday) if no type or type=1 is 

 specified.  

 If type=2, numbering begins at Monday=1; and if type=3 numbering begins at Monday=0. 

Syntax : WEEKDAY(Number; Type) 

 Number, as a date value, is a decimal for which the weekday is to be returned. 

 Type determines the type of calculation. 

 

  For Type=1, the weekdays are counted starting  from Sunday (this is the default even 

 when the Type parameter is missing). For Type=2, the weekdays are counted starting 

 from Monday=1. For Type=3, the weekdays are counted starting from Monday=0. 

Examples 

=WEEKDAY("2000-06-14")  returns 4 (the Type parameter is missing, 
therefore the standard count is used.  

The standard count starts with Sunday as day number 1.  

June 14, 2000 was a Wednesday and therefore day number 4). 

 

=WEEKDAY("1996-07-24";2)  returns 3 (the Type parameter is 2, therefore 
Monday is day number 1.  



July 24, 1996 was a Wednesday and therefore day number 3). 

 

=WEEKDAY("1996-07-24";1)  returns 4 (the Type parameter is 1, therefore 
Sunday is day number 1.  

July 24, 1996 was a Wednesday and therefore day number 4). 

 

=WEEKDAY(NOW()) returns the number of the current day. 

 

2.3 Data :  

 2.3.1 Sort Data, Filter Data  

  

 SORT DATA 

• Sorting arranges the cells on the sheet.  

• In Calc, you can sort by up to three criteria, with each criterion applied one after the other.  

• In addition, sorting is often useful when you add new information.  

• After you have added information, you can then sort it to update the sheet. 

• Highlight the cells to be sorted, then select Data > Sort to open the Sort dialog, or click 

the Sort Ascending or Sort Descending toolbar buttons. 

• Using the dialog, you can sort the selected cells using up to three columns, in either 

ascending (A-Z, 1-9) or descending (Z-A, 9-1) order. 

 
 



       
 

• You can also select sort ascending and descending option fro

 

 FILTER DATA 

• Filtering data in a spreadsheet means to set 

It is done to make it easier to focus on specific information in a large

data. 

→ Filters works with records or rows of data in the database. The conditions that are 

set are compared with one or more

the record is displayed.

→ If the conditions are not met, the record is filtered out so that it isn't displayed 

with the rest of the data records.

→ Filtering does not permanently remove records; it just temporarily hides them 

from view. 

→ For open filter option select data 

→ There are three type of filtering: 

[1] Auto filter  

[2] Standard filter  

[3] Advance filter. 

 

1. Auto Filter 

• It is the simplest filter. 

• It is apply on a specific column.

• After creating an auto filter for a specific column, a 

The combo box provides quick access to each of the auto filter types.

 

You can also select sort ascending and descending option from tool bar.

 

in a spreadsheet means to set conditions so that only certain data is displayed. 

It is done to make it easier to focus on specific information in a large database

th records or rows of data in the database. The conditions that are 

set are compared with one or more fields in the record. If the conditions are met, 

splayed. 

If the conditions are not met, the record is filtered out so that it isn't displayed 

with the rest of the data records. 

Filtering does not permanently remove records; it just temporarily hides them 

For open filter option select data from menu bar -> select filter. 

There are three type of filtering:  

 

 

It is apply on a specific column. 

After creating an auto filter for a specific column, a combo box is added to the column. 

The combo box provides quick access to each of the auto filter types. 

 

m tool bar. 

conditions so that only certain data is displayed. 

database or table of 

th records or rows of data in the database. The conditions that are 

in the record. If the conditions are met, 

If the conditions are not met, the record is filtered out so that it isn't displayed 

Filtering does not permanently remove records; it just temporarily hides them 

combo box is added to the column. 



 

• The All auto filter causes all rows to be visible. 

• The Top 10 auto filter displays the ten rows with the largest value. An auto filter entry is 

created for each unique entry in the column. 

• To create an auto filter, first select the columns to filter.  

• You can place the auto filter in any row, only the rows below the auto filter are filtered.  

• Remove an auto filter by repeating the steps to create the auto filter— unchecked the 

option auto filter. 

 

 

 

2. Standard Filter 

• Use Data > Filter > Standard Filter to open Standard Filter dialog and limit the view based 

on 1 to 3 filter conditions. Use Data > Filter > Remove Filter to turn off the filter. 

• Standard filter is used for multiple filtering the data.(see figure) 

• As shown in figure we can filter data on particular condition base. Also we can filter data 

by comparing more than 2 conditions. 

 

 

 

3. Advance Filter 

• An advanced filter supports up to 8 filter conditions. 



• The criteria for an advanced filter is stored in a sheet.  

• The first step in creating an advanced filter is entering the filter criteria into the 

spreadsheet. 

• Select an empty space in the Calc document.  

• Duplicate the column headings from the area to be filtered into the area that will contain 

the filter criteria. 

• Enter the filter criteria underneath the column headings. The criterion in each column of a 

row is connected with AND. The criteria from each row are connected with OR. 

• After creating one or more sets of filter criteria, apply an advanced filter as follows: 

• Select the sheet ranges that contain the data to filter. 

• Use Data > Filter > Advanced Filter to open the Advanced Filter dialog. 

• Select the range containing the filter criteria and any other relevant options. 

• Click OK. 

 
 

 2.3.3 Consolidated Data ( sum, count, max, min, average) 

• Data > Consolidate provides a way to combine data from two or more ranges of cells into 

a new range while running one of several functions (such as Sum or Average) on the data. 

During consolidation, the contents of cells from several sheets can be combined in one 

place. 

1. Open the document that contains the cell ranges to be consolidated. 

For proper understanding let's take an example:  

• Create a new spread sheet. 

• In Sheet1,  Add records for Deposited and withdraw amount for the month January as 

shown below. 
 

 
Shhet1-Jan 1 



 

• In Sheet2,  Add records for 

shown below. 

Sheet-2 FEB Month 1 

• Use another sheet-3 for display result. 

2. Choose Data > Consolidate

after making the changes described below.

It will open dialog box as shown below.

 

 

,  Add records for Deposited and withdraw amount for the month 

 

3 for display result.  

Data > Consolidate to open the Consolidate dialog. The figure shows this dialog 

changes described below. 

 
It will open dialog box as shown below. 

amount for the month February  as 

to open the Consolidate dialog. The figure shows this dialog 

 



Different functions are available in Function Option. 

 

3. As per data of sheet1 and sheet2, here we want to calculate deposit amount and 

withdraw amount of January and February. And we want to display result in Sheet-3. 

 

4. Select appropriate function from function dialog box. Here to calculate amount we use 

SUM function. As shown in figure above. 

 

5. As per figure if Consolidate data range is not blank then first clear these data.  

for this, select data range -> delete option. 

 

 
 

6. Now in next step select source data range option from dialog box shown in step-2. And 

select data from sheet-1. For that click on Shrink icon  

 
 

And then add this range by clicking in Add button. It will add data range to the Data rande 

option. 

 
 



7. Perform same step to add Sheet-2 data. 

8. In next step select copy result to option. For add result sheet-3. For that click on shrink 

button. 

 
Sheet-3 RESULT 1 

9. Click on more option from dialog box it will display some more button. 

 
 

Here, link to source data option must be checked.   

If we make any changes in sheet-1 and sheet-2 that will affect the result in sheet-3, if 

we this option is checked. 

 

10. Finally click on OK button.  so sheet-3 display result. 

 
 

Same way we can use average, count ,min and max functions also. 

 

� Step to removing duplicate data. 
 

� Step 1:  Select the data that you want to filter. After that Go to Data >> Filter >> 

Standard Filter. 

 



 

 

 

� Step2 : Click on More Options. This will take you to more advanced options. 
 

 



 

� Step 3: Click on No Duplicates. Change Field Name to 'none'. If you want to create a 

separate list, click on Copy To... and select a cell address; such as B1. 

 

 

 

� Step 4: Select Ok. You will be taken back to your list with the duplicates removed. 

 
 

Final output will be below. 

 



 

 

 

 


